alphaFeedback

WorksComputer Science

From TCP/IP to MCP: Security and Governance Lessons from Internet Protocols for Agentic AI

AI contributions
Not recorded for this paper
View details

Abstract

The past two years have seen considerable interest in protocols for managing how AI agents interact with human users, external tools, and each other. In many ways, these protocols, including the Model Context Protocol (MCP) and Agent2Agent (A2A), mirror the suite of protocols that underlie the modern internet. Motivated by this parallel, this paper draws lessons from the development, history, and governance of internet protocols with the aim of informing the responsible development of AI agent protocols. Based on our analysis, we make two conclusions. First, if AI agent protocols do not sufficiently prioritise security in the early stages of development, they risk accumulating a security deficit that becomes increasingly costly to address over time due to practical and economic challenges. Second, current governance structures for AI agent protocols centralise decision-making power in a small number of individuals and companies, raising important questions regarding legitimacy, especially if they become critical digital infrastructure. We conclude with a discussion and implications for policymakers and developers of AI agent protocols.

Introduction

AI agent protocols are emerging rapidly as a way to enable interoperability between agents, external tools and users. A protocol is a standardised set of rules governing the format and exchange of data between systems; in practice, the boundary between a ‘protocol’ and a ‘standard’ for technology is blurred, with protocols often becoming standardised through adoption. The predominant example, the Model Context Protocol (MCP), released by Anthropic in November 2024, has grown rapidly with over 170,000 supported tools [88] and backers including OpenAI, Amazon, and Google. MCP is increasingly referred to as being in the process of becoming standardised digital infrastructure [see e.g. 64].

These protocols functionally mirror those developed at the end of the 20th century that underlie the internet, with both facilitating communication and interoperability between heterogeneous systems. Inspired by this parallel, this paper draws lessons from internet protocols to inform the development of AI agent protocols. We focus on security and governance of protocols as areas where internet and agent protocols share structural similarities despite content-level differences. We explicitly exclude considerations of geopolitics in standard-setting, while acknowledging that standards and protocols development can be an active arena for advancing geopolitical power [30, 37].

While the comparison can be instructive, it is not perfect. In particular, internet protocols emerged from publicly-funded research over decades, while AI agent protocols have been developed commercially in months. However, the rapid rate of uptake of AI agent protocols only increases the timeliness of any lessons that can be learnt from the history of the internet. As these protocols become embedded in how AI systems interact with the world, decisions made now about their design, security, and governance will shape who benefits, who bears the risks, and who gets a say.

Throughout the paper, we draw on MCP as a running example due to its current position as the most widely-used and most-developed AI agent protocol. While other AI agent protocols are available, such as Agent2Agent and the Agent Communication Protocol, MCP offers the greatest evidence base from which to draw a comparison to internet protocols. When considering protocol governance, we primarily focus on the Internet Engineering Task Force (IETF) given its stewardship of the majority of internet protocols, including TCP, IP, HTTP, TLS/SSL, and DNS.

Authors’ Contact Information: Ben Bucknall, [email protected], University of Oxford, UK; Andrew Byrley, Independent, USA; Lewis Hammond, Cooperative AI Foundation, UK. Based on our analysis, we make two primary conclusions:

  • Retrofitting security measures to existing protocols is challenging due to practical and economic challenges. Early internet protocols deprioritised security, contributing to a decades-long security debt. If AI agent protocols do not sufficiently prioritise security in the early stages of their development, they risk accumulating a similar security deficit that becomes increasingly costly to address as adoption grows.

  • Internet protocols are embedded in a unique governance structure with formal mechanisms for accountability and community input, including at the highest levels of leadership, though whether these mechanisms translate to openness in practice is disputed. In contrast, AI agent protocols have emerged with a governance structure that centralises decision-making power in a small number of individuals, raising concerns about legitimacy in the case that these protocols become critical digital infrastructure.

Alongside sections motivating each of these conclusions (§ 3 and § 4, respectively), § 2 provides relevant background information and § 5 discusses the two conclusions, how they interact, and highlights concrete implications for key stakeholders.

Background

A Short History of Internet Protocols

The internet’s origins lie in the Advanced Research Projects Agency Network (ARPANET), a U.S. Department of Defense project first operational in late 1969, designed to enable resource-sharing between geographically dispersed research computers [58]. Critically, the host-to-host communication protocol was designed not by ARPA officials or by the contractors that built the network hardware, but by an informal group of graduate students who called themselves the Network Working Group (NWG) [68]. The NWG designed the Network Control Program (NCP), ARPANET’s first host-to-host protocol [25], which assumed a single, homogeneous network.

NCP was unsuitable for internetworking. In the early 1970s, DARPA was building packet radio and packet satellite networks that NCP could not accommodate due to differing packet sizes, latencies, and failure modes [21, 58]. This problem was solved in September 1981 by a pair of protocols: the Internet Protocol (IP) [70], a connectionless datagram protocol responsible for addressing and routing, and Transmission Control Protocol (TCP) [71], a reliable byte-stream transport. On January 1, 1983 NCP was permanently disabled on ARPANET and TCP/IP became the sole operational protocol [58]. By the time that commercial restrictions on internet traffic were lifted in 1995, TCP/IP was already the foundation of global networking [58], catalysed by the introduction of the World Wide Web in August 1991 [11].

The institutional home for internet protocol development, the Internet Engineering Task Force (IETF), grew directly out of this ARPANET community and was spun off as an engineering-focused task force in January 1986. The IETF’s cultural charter was reflected by David Clark at the 1992 Cambridge plenary: ‘We reject: kings, presidents and voting. We believe in: rough consensus and running code’ [23]. Unlike traditional standards-setting organisations, governments play no formal role in the IETF, and as such, it lacks national delegations, treaty obligations, and reserved government seats. We return to the details of the IETF’s governance structure, and its contrast with MCP’s, in § 4.1.

The primary vehicle for IETF standards development is the Request for Comments (RFC) series, which predates the IETF itself. The name ‘Request for Comments’ was deliberately chosen to signal informality, reflecting ‘the basic ground rules [...] that anyone could say anything and that nothing was official’ [26]. What began as informal notes among a handful of ARPANET researchers became the authoritative document series for internet standards. Along with technical specifications, RFCs also encompass governance and process documents,1 philosophical statements,2 ethical guidelines,3 humour,4 and the RFC process itself.5

The principal competitor to TCP/IP in the 1980s was the ‘Open Systems Interconnection’ (OSI) model, developed through formal international standards processes. OSI was developed by the International Organization for Standardization (ISO) and the International Telegraph and Telephone Consultative Committee (CCITT, now the ITU-T – the Telecommunication Standardisation Sector of the International Telecommunication Union). It enjoyed powerful institutional backing, being endorsed by the European Community, national post, telephone, and telegraph administrations (PTTs) [77], and major vendors including IBM and DEC [78]. Yet TCP/IP was already deeply entrenched in the research and university communities and its user base was growing rapidly [58].

The two efforts embodied different approaches to protocol development. The IETF’s process required that protocol proposals be accompanied by working implementations; specifications evolved through iterative testing and deployment, not committee negotiation. OSI, by contrast, aimed to produce complete, formally specified standards through a multiyear, delegation-based process involving national standards bodies before implementations existed. The consequences of these competing approaches were significant. The need to reconcile competing interests within ISO produced enormous specification complexity, which made interoperable implementation difficult in practice [77]. By the early 1990s, many of the ISO committees working on OSI standards were coordinating their own work over TCP/IP-based email – conducting their deliberations on the very infrastructure whose intended replacement they were designing [77]. Amplified by the explosive growth of the World Wide Web after 1993, displacement of TCP/IP became effectively impossible [77] and mandates for the adherence to the OSI model faded in both the US and EU. OSI as a deployed protocol suite effectively ceased to exist [77], although individual OSI-derived standards survived in specific niches.6

AI Agent Protocols to Date

Similarly to how internet protocols are specifications for mediating connections between individual users and machines, AI agent protocols specify the structure of how AI agents interact with external tools, human users, and each other. By standardising these interactions, protocols serve to make it easier for individual agents to reliably perform actions in the real world, while also providing the opportunity for attribution, oversight, and certification [22]. While protocol development for AI agents has progressed rapidly in recent years, the concept was discussed much earlier, for example in Wooldridge [94], who characterises protocols as defining “the ‘rules of encounter’ between agents.”

Numerous efforts to develop AI agent protocols are underway within government, industry, and academia. For example, the National Institute for Standards and Technology (NIST) in the US has launched an AI Agent Standards Initiative to promote the trusted adoption of AI agents and “cement U.S. dominance at the technological frontier”.7 So far, the initiative has supported a concept paper on ‘Software and AI Agent Identity and Authorization’ [14], and a request for comments regarding ‘Security Considerations for AI Agents’.8 Elsewhere, the ITU has started developing standards specifically focussed on AI agents [48], as has the China Academy of Information and Communications Technology [90]. Finally, while its standards to-date are not specifically focused on AI agents, much of the ISO’s work on AI – for example throught its ISO/IEC JTC 1/SC42 committee – is directly relevant [62].

A larger number of proposed protocols have come from industry and academic sources, variously focussing on agent-agent, agent-user, or agent-tool interactions [96]. While such proposals don’t have the explicit aim of defining a formal standard, as seen in the case of internet protocols, it is not uncommon for informal proposals to become de facto standardised if they secure enough buy-in among users and developers. Examples include Agent2Agent (A2A) and Agent Communication Protocol (ACP), released by Google in April 2025 and IBM in March 2025, respectively, both of which focus on inter-agent communication and collaboration [60, 89]. Others, such as AG UI, developed by CopilotKit focuses on the interaction between user interfaces and AI agent-based backends.9 While many of these examples are stewarded and supported by private industry actors, they take the form of open-source projects with a focus on developing functional implementations of protocols rather than abstract frameworks.

The Model Context Protocol (MCP) has emerged as the predominant AI agent protocol since its release by Anthropic in November 2024. Framed as a ‘USB-C port for AI applications’, MCP provides a standardised format for AI agents to interact with external tools as a way of addressing the previously fragmented landscape, where each pair of agent and tool might have a unique way of interacting [34, 96]. Following its release, MCP quickly gained traction within the community and corporate buy-in, notably with OpenAI supporting MCP across its products from March 2025.10 The MCP ecosystem has grown to include tens of thousands of servers – lightweight programs that expose tools to agents – and hundreds of thousands of distinct tools [88]. In December 2025, Anthropic donated MCP to the Agentic AI Foundation (AAIF), a subsidiary of the Linux Foundation, which it founded along with other companies including OpenAI and Google. We discuss the AAIF and its governance structure and implications further in § 4.

On the Comparison of Internet and AI Agent Protocols

Having provided an overview of the history of internet protocols and ongoing developments in AI agent protocols, we now discuss in more detail the motivation for making this comparison. We outline similarities regarding what purpose the protocols are intended to serve, how they’re developed, and by whom, as well as ways in which they contrast.

The similarity between internet protocols and AI agent protocols at a functional level is that both aim to address problems of interoperability and heterogeneity within their domains. In particular, TCP/IP standardised the format in which data could be transferred between computers of varying architectures, running different operating systems. In comparison, AI agent protocols standardise the format in which agents interact with users, tools, or other agents. For example, rather than AI agents needing to structure a tool call in a different way for each tool, MCP defines a single format that can be used with a large number of potential tools. As a result of this focus on interoperability and interconnectivity, both kinds of protocols are subject to network effects whereby the benefits of an individual adopting the protocol are proportional to the number of existing adopters [55, 65].

Furthermore, in both the case of TCP/IP and industry-led AI agent protocols, the specification is approved by a centralised authority, though amendments, updates, or extensions can be proposed by the broader community. The approved standard then serves as reference for implementation by third-parties that are nonetheless able to deviate from the specification. This means that the success of standardised protocols stems from soft power and network effects rather than any mandated use, and that the individual or group with power to define the specification exercises significant power over the ecosystem without any formalised authority.

At an ecosystem level, both internet and AI agent protocols are advanced by a range of organisations and institutions. As taxonomised by Biddle [13], these include ‘formal standards development organisations’ (SDOs) such as the ISO and ITU and ‘consortia’ – industry-led organisations that lack government recognition or authority – such as the IETF and AAIF. Biddle [13] also discusses ‘single promoter standards’ – standards that are developed and promoted by a single company. Anthropic’s initial development of MCP can be seen as an example of this category.

Alongside the similarities, there are also numerous differences worth noting. First, while early internet development was overwhelmingly supported and funded by the US Department of Defense through DARPA, (implemented) AI agent protocols are almost entirely the result of private, corporate funding. As such, while the internet was initially intended as an inherently national security-relevant technology, rather than one used by the broad public, companies developing AI agent protocols may view them as a commercial asset, product, or service. Indeed, MCP, the first widely-adopted AI agent protocol, was initially developed by a single private company.

Second, AI agent protocols have experienced a dramatically faster rate of uptake than the internet. Stein [88] identifies over 70,000 potential MCP servers as of February 2026 – approximately 15 months after MCP’s initial launch. In comparison, it took approximately two decades for the internet to reach a comparable number of hosts [97]. This may be a direct result of the difference in initial purpose noted above, in that the internet was initially a closed community of academics developing defence infrastructure. While the user base of AI agent protocols remains highly technically-literate, there is uncertainty regarding whether this will shift to encompass a broader, less-technical subset of the general public, as was seen for the internet.

Overall, while these differences mean that the analogy is imperfect, the structural similarities between internet and AI agent protocols – both at the functional and ecosystem level – suggest that the comparison is informative. In the following two sections we compare the development of internet and AI agent protocols, particularly with regards to their security properties and governance structures.

The Challenges of Retrofitting Security

In this section we discuss the history of internet security, and how excluding security as an initial design goal created challenges when it came to retroactively implementing security measures – that is, technical defences against the misuse of the internet for malicious ends. We also provide a brief overview of security in MCP, arguing that, if neglected in these early stages of MCP’s development, implementing security will face similar challenges. As a way of structuring the discussion, we introduce two complementary categories of practical and economic challenges to retrofitting security.

Practical challenges occur when, despite the existence of secure protocols, implementation is bottlenecked by material constraints. This may be due to implementation costs or performance trade-offs. For example, performing cryptographic verification can introduce a small but real computational overhead to communication protocols [63]. Having to retroactively implement security to existing protocol suites raises additional practical challenges, such as minimising service disruption, as well as ensuring interoperability and backwards-compatibility [8]. Moreover, maintaining backwards compatibility with insecure legacy systems can itself introduce new attack vectors that exploit continued support for deprecated protocol versions [49].

Economic challenges occur when implementing security, while not theoretically or practically challenging, is disincentivised or inhibited. For example, uptake of secure protocols may be slowed by collective action problems whereby, despite manageable implementation costs, the benefit to each actor is negligible unless all other actors also implement the secure protocol [9, 41, 57, 91]. Anderson and Moore [4] provide an influential overview of the economic factors at play in information security, arguing that ‘incentives are becoming as important as technical design in achieving dependability.’ These challenges are compounded when security must be retrofitted, as secure protocols must then compete with insecure alternatives that are already broadly deployed. For example, actors may anchor on the cost of an insecure ‘status quo’, making them less likely to pay extra for security, even if they would have paid the higher price if no alternative was available [52, 69, 74, 81].

The Internet’s Persistent Security Deficit

As discussed in the previous section, the modern internet emerged out of a small and closed network of trusted users, predominantly in academia, in the 1970s [29]. At the time, personal computers were not yet commonplace, and ‘public or home access [to the internet] seemed implausible’ [29 p. 683]. As such, security was not considered to be a priority. On the contrary, it was deemed to be both infeasible and undesirable [35]:

A community of scholars should not have to build walls as high as the sky to protect a reasonable expectation of privacy, particularly when such walls will equally impede the free flow of information. Besides, attempting to build such walls is likely to be futile in a community of individuals possessed of all the knowledge and skills required to scale the highest barriers.

A watershed moment came in November 1988 when the then-Cornell graduate student Robert Morris developed and released a self-replicating computer program (what’s now termed a ‘worm’) on the internet, disabling over 6,000 computers11 [29, 35]. The ‘Morris Worm’, as it has since become known, exposed the weaknesses in relying on interpersonal trust and academic integrity for securing a growing network. Around the same time, Steve Bellovin published a paper outlining multiple ‘serious security flaws inherent in the [TCP/IP suite of] protocols’ [10]. For example, since TCP/IP lacked a method for verifying the stated source address of packets sent over the network, attackers could impersonate a trusted host and, in combination with predictable protocol behaviour, execute commands on remote systems without authentication [10]. Over the ensuing decade, internet user numbers rose rapidly, catalysed in part due to the advent of the World Wide Web in the early 90s, with many new users coming from outside the academic communities which comprised much of the early user base. As a result, the heavily trust-based model on which the early internet operated became outdated. Combined with commercial and corporate interest in e-commerce, the need for greater internet security was becoming apparent [29]. Costly worms and viruses underscored this need, and remained commonplace into the 2000s, with examples such as the ‘Love Bug’ virus (2000), ‘Code Red’ (2001), and ‘Mydoom’ (2004) requiring billions of dollars to combat [29].

In spite of the rising costs of security vulnerabilities, adoption of more secure protocol variants has historically proven sluggish. One prominent example is that of retrofitting encryption to the Hypertext Transfer Protocol (HTTP) – the protocol underlying the World Wide Web. HTTP/1.0 was published as a standard in 1996 as RFC 1945 [11], having gained broad adoption during its draft status. However, HTTP did not natively support encryption, meaning that all information transferred using it was liable to man-in-the-middle attacks such as eavesdropping, tampering, or forgery.

Around the same time, Netscape was developing the Secure Sockets Layer (SSL), a proprietary protocol for cryptographically securing the transmission of data over TCP connections, with HTTP being the primary motivation. SSL was later adopted by the IETF, rebranded to Transport Layer Security (TLS), and published in RFC 2246 in 1999 [31]. ‘HTTP over TLS’ or simply ‘HTTPS’ was standardised in 2000 as RFC 2818 [75]. Despite all technical pieces being in place by the late 1990s, HTTPS adoption remained confined to a narrow set of use cases – primarily financial transactions, where payment card industry requirements mandated its use [65]. The broader web remained unencrypted for two decades. In 2017, half of the most popular websites were still HTTP by default, and most smaller websites did not support HTTPS at all [38]. The barriers to greater uptake identified in the literature were practical and economic rather than technical. For example, it was costly to acquire a TLS certificate – a prerequisite for allowing users to connect using HTTPS – and deployment was a ‘notoriously difficult process’ [12] deemed to be ‘far too complex even for people with proficient knowledge in the field’ [53]. With unencrypted HTTP as the entrenched default and minimal direct costs to web servers for not providing secure connections, the additional burden of deploying HTTPS proved prohibitive for many smaller actors. It took structural changes such as Let’s Encrypt providing a cheaper and simpler method for acquiring TLS certificates [1], browsers warning users when connecting to insecure websites [39], and the US government requiring all federal websites to support HTTPS by the end of 2016 [84] to finally make the use of HTTPS widespread.

While many similar cases have been individually documented, when read together they exhibit a common pattern of widespread adoption of secure internet protocols being hindered by practical and economic challenges, long after the technical substrate was in place. IPv6, despite being standardised as a successor to IPv4 in 1998 [27], still only serves around 50% of internet users12 due to a lack of backwards compatibility imposing significant costs on early adopters [30, 55, 95]. Domain Name System Security Extensions (DNSSEC) – the suite of protocols that adds cryptographic attestation to the directory that maps domain names to IP addresses – was introduced in 2005 [5, 6, 7], yet remains at single-digit adoption rates,13 partly due to collective action problems [65]. Finally, Resource Public Key Infrastructure (RPKI) [59], a solution to insecurities in the Border Gateway Protocol (BGP), has only recently attained 50% coverage, with adoption slowed by similar organisational challenges [42].

A common theme among all these examples (HTTPS, IPv6, DNSSEC, RPKI) is that, despite the technology being functional, practical and economic considerations – such as coordination problems and large upfront costs to first-movers – considerably slowed the uptake of security. Often this was further hindered by secure protocols having to compete with existing but insecure alternatives, which could increase switching costs, demand backwards compatibility, or serve as an anchor against which performance is measured. In many cases it took structural changes in the form of regulatory mandates [84], free or automated tooling [1], and changes to default behaviour by major platform providers to achieve widespread use of secure protocols [39]. As we argue in the following section, there is reason to believe that these dynamics will generalise to AI agent protocols.

Security Challenges for AI Agent Protocols

Despite its relative nascency, MCP has already experienced a number of security issues and flaws, and a considerable amount of research has been carried out analysing its security profile (see e.g. 3, 24, 36, 43, 46, 73, 98). For example, Hou et al. [46] formalise a threat taxonomy according to four potential attacker types: malicious developers, external attackers, malicious users, and security flaws. Notably, they find that, ‘despite the rapid adoption of MCP, its ecosystem is still in the early stages, with key areas such as security, tool discovery, and remote deployment lacking comprehensive solutions’ [46]. Examples of the security issues highlighted include ‘command injection’, where an attacker inserts malicious logic into a server’s source code, and ‘unauthorized access’ attacks where attackers are able to interact with systems beyond intended permissions due to ‘weaknesses in authentication, transport, or session management’ [46]. Instances of these vulnerabilities have been observed. For example, an unofficial Postmark email MCP server ‘built trust over 15 versions’ before secretly adding a backdoor that ‘BCC’d emails to an external server.’14

While MCP acknowledges potential security issues, current approaches to dealing with risks to safety and privacy place the responsibility on downstream developers and end users. For example, the protocol specification states that ‘users must explicitly consent to and understand all data access and operations’ and that ‘users must retain control over what data is shared and what actions are taken.’15 Furthermore, while the MCP registry – an official and open catalog of publicly available MCP servers – includes a ‘community-driven mechanism for moderation’,16 it defers security opportunities such as ‘source code scanning’ and ‘tool poisoning countermeasures’ to later iterations of the registry.17

If not addressed in the near-term while MCP is still scaling, implementing solutions to many of these security weaknesses may prove challenging due to the practical and economic effects discussed in the previous section. There has already been a case in which practical considerations, in the form of backwards-compatibility, played a role in MCP’s evolution. Authorisation through OAuth [45] was first introduced to MCP as an optional feature in the March 2025 specification as a way of handling authorisation for accessing restricted servers.18 Initially, the specification relied on Dynamic Client Registration (DCR) [50] as a way of allowing clients to register with servers at runtime [67]. However, DCR was seen to place too much onus on developers of MCP servers who often didn’t have the necessary expertise to implement it correctly [28]. In a study of real-world remote MCP servers that implement authorisation, Zhou et al. [99] found that 96.6% of tested servers exhibited a flaw with DCR, such as allowing attackers to intercept authorisation codes. As such, the November 2025 MCP specification moved towards an alternative approach – Client ID Metadata Documents (CIMD) – but retains support for DCR as a fallback for the purposes of backwards compatibility.19 As MCP continues to grow, similar dynamics are likely to recur, with the difficulty of migrating to improved approaches – and the security costs of maintaining legacy ones – only increasing with adoption.

Furthermore, in April 2026, OX Security disclosed that the use of stdio transport for launching MCP servers as local subprocesses passes the command given in a client’s configuration directly to the operating system without validation. This can facilitate arbitrary code execution if an attacker is able to influence the configuration [85]. Since this logic is built into the official MCP SDKs, it is inherited by all servers that are built on them. One of the proposed protocol-level fixes was to implement manifest-only execution, meaning that a client would only launch verified servers rather than executing an arbitrary command string. However, Anthropic responded by stating that this is not a vulnerability in MCP, since its trust model assumes that client configurations are trusted, and so the responsibility is on the host application’s developer to implement safeguards. This position was clarified in an update to MCP’s security policy.20 The proposed fix would have broken the launch path for every existing stdio server, requiring server authors to publish conforming manifests and client implementers to enforce them, with the cost of coordination rising as the ecosystem grows.

Despite this section’s focus on practical and economic security challenges, it is worth noting that, for many issues in AI agent security, we do not yet have robust technical solutions. Many of the observed vulnerabilities of MCP discussed above stem from weaknesses in agents themselves in the face of ‘agent traps’ [40]. For example, tool poisoning relies on LLMs’ susceptibility to jailbreaking. These are analogous to social engineering attacks such as phishing, which exploit the human user rather than the protocol, but which the protocol nonetheless enables. In the internet case, however, the attacker-defender dynamic is grounded in the relative stability of human psychology. For example, innate human susceptibility to scams tends not to vary much. The same cannot be said of AI agents, whose underlying models are @referencesанӡа frequently updated. This means that the attack surface the protocol must contend with is itself shifting on the timescale of months, but also that security advances could come through updates to agents themselves. Combined with the field’s still-limited understanding of LLM robustness [56], this makes the residual risk that persists after protocol-level security measures less predictable than its internet-era analogue. Authentication, authorisation, and verification remain essential for MCP, but they are unlikely to be sufficient.

Discussion

Above, we have argued that AI agent protocols are likely to face similar practical and economic challenges to implementing security measures as seen in the case of internet protocols. This argument largely follows from the observation in § 2.3 that both internet and AI agent protocols are subject to network effects – once users have adopted a particular version of a protocol, updating the entire ecosystem to a newer, more secure version naturally encounters a coordination problem. While it is possible that MCP has already reached this stage given the tens of thousands of servers already in use, we do not empirically establish any existing security deficit in MCP. Rather, we have argued that the conditions under which such a deficit could emerge are present, and suggest empirical studies of security in the MCP ecosystem as valuable future work.

If it is the case that network effects are slowing the adoption of security in MCP, what can be learnt from internet protocols? The example of HTTPS discussed above points towards three events that spurred adoption: easy and free tooling (Let’s Encrypt), changes to default system behaviour (browsers warning when connecting via non-encrypted HTTP), and mandated adoption (US federal websites requiring encryption). This suggests potential analogous interventions that could incentivise the uptake of secure AI agent protocols. For example, protocol developers or third-parties could develop public tooling that makes scanning and certification of MCP servers free and automated. Official MCP software development kits (SDKs) could include default behaviour that alerts the user if their agent is connecting to a tool server that has not been verified or certified. Major enterprises or government agencies could require that critical servers are verified or certified. Ultimately though, these interventions are able to incentivise the uptake of secure protocols only once they have been technically defined and incorporated into the protocol specification – something that, for many critical security features, is still lacking.

Governance and Legitimacy in Protocol Development

In this section, we explore and compare the governance and decision-making structures adopted by the dominant protocol development bodies responsible for developing internet and AI agent protocols – namely, the Internet Engineering Task Force (IETF) and Agentic AI Foundation (AAIF), respectively. We find notable differences in approach. While the IETF has evolved over decades to adopt participatory approaches to both low-level protocols development and high-level strategic planning, the AAIF and MCP have adopted structures that centralise decision-making authority in a small number of industry representatives, with few inroads for community participation at the highest level.

Internet Protocols: The IETF

As introduced in § 2.1, the IETF serves as the predominant body in internet standards and protocols development, with protocols including TCP/IP, HTTP, and SSL/TLS [44]. Initially formed in 1986 as a working group for the expanding set of internet users, particularly at universities, the IETF quickly gained traction and became open to all interested individuals within two years of its foundation [79]. This focus on openness, along with technical merit and action through broad consensus, has since been codified through RFCs as formal structures and processes for the body [see e.g. 2, 15–17, 54, 80].

The openness of the IETF is represented by the fact that ‘there is no membership in the IETF.’21 Participation, for example by signing up to a working group, is open to any interested individual. While all participation is considered by the IETF to be on a voluntary and individual basis, tech companies can, and do, employ individuals to contribute full-time, with many key protocols being proposed by contributors from a handful of companies [44 p. 38]. Decisions are made by rough consensus – often indicated by humming – rather than formal voting procedures, with working group chairs responsible for deciding when consensus is reached and ensuring that objections are addressed [76].

While the technical ground work is carried out within working groups, there is a large amount of higher-level strategic and administrative work required to keep the IETF running (see Figure 1). This is the purview of a number of bodies including: the Internet Architecture Board (IAB), the most senior technical body that sets long-term technical direction; the Internet Engineering Steering Group (IESG), which is responsible for the protocol development process, including providing final approval for RFCs; IETF Administration LLC (IETF LLC) which serves as the legal, financial, and operational centre; and the IETF Trust which manages the IETF’s intellectual property [80].

Structure of the IETF and inter-related organisations

Figure 1. Structure of the IETF. By Jay Daley – https://www.ietf.org/media/documents/IETF_Structure_-_February_2022.png, CC BY 4.0, https://commons.wikimedia.org/w/index.php?curid=144203249

One of the most distinctive features of IETF’s governance is the Nominating Committee (NomCom). Composed of 10 randomly selected22 contributors serving year-long terms, the NomCom has broad powers and responsibilities for appointing members to leadership positions across the IETF structure, including the boards of the IAB, IESG, and IETF LLC [54]. Eligibility for the NomCom is subject to certain criteria, but can be satisfied, for example, by attending three of the past five IETF meetings [32]. Furthermore, upon petition by 20 IETF members meeting the same eligibility criteria, a Recall Committee can be established according to the same processes as the NomCom with the power to recall (i.e. remove) any member of the IESG, IAB, or other NomCom-appointed leader by three-fourths majority [54].

However, despite adopting a formal governance structure that emphasises open participation, the IETF has received criticism, including for alleged corporate capture due to companies’ employing individuals to participate in the standards setting process ‘as individuals’ [44]. Furthermore, analysis has shown that formal openness may not translate to decentralisation, with 32%-42% of RFC drafts between 2010 and 2019 authored by the top 10% most influential contributors [51]. Critics have further pointed towards ‘cultural barriers to openness’ in the IETF, including ‘confrontational working practices’ that exclude input from non-profit organisations [19].

AI Agent Protocols: MCP and the AAIF

In this subsection, we provide the first comprehensive analysis of the governance structure surrounding MCP following this donation to the LF, drawing on charters, tier structures, and public governance documentation. We compare the structure that has emerged since MCP’s founding donation to the Agentic AI Foundation (AAIF) in December 2025 to other LF directed funds, namely the Cloud Native Computing Foundation (CNCF) and the PyTorch Foundation.

MCP itself follows a largely standard open-source project governance hierarchy consisting of: a pair of ‘lead maintainers’, a ‘lifetime appointment’ which holds ‘ultimate authority over MCP’s direction and governance’; a group of six ‘core maintainers’, holding ‘final decision-making authority for MCP’s technical direction’; and a broader community of ‘maintainers’, ‘members’, and ‘contributors’ (in descending order of responsibility) [87]. There is ‘no formal requirement’ for becoming a contributor, other than contributing to MCP in any form [87]. While the positions of ‘member’ and ‘maintainer’ are broadly attainable on a meritocratic basis, the core maintainer role is ‘intentionally limited’ to ensure a ‘coherent technical vision while the project scales’ [87]. Roughly in line with the ‘Benevolent Dictator For Life’ (BDFL) model of open-source governance, the lead maintainer role is ‘a lifetime appointment reserved for project founders’ which is only assumed through succession rules if an existing lead maintainer leaves the role [86].

The AAIF is a ‘directed fund’ under the Linux Foundation (LF) which stewards MCP alongside five further projects: OpenAI’s ‘AGENTS.md’ and Block’s ‘goose’, which were donated at launch, as well as ‘agentgateway’, ‘Agent2Agent’ (A2A), and ‘Agent Router’ which joined in June, August, and September 2026, respectively.23 The AAIF has a membership base of mostly private companies with some academic institutions, as is standard for LF directed funds. These members are organised according to tiers which provide differing levels of representation and input into high-level decision-making in exchange for increased membership fees. In the case of AAIF, these tiers are called ‘platinum’, ‘gold’, ‘silver’, and ‘associate’.24 The eight platinum members have the largest influence over the governance and direction of the AAIF and are currently: AWS, Anthropic, Block, Bloomberg, Cloudflare, Google, Microsoft, and OpenAI.25 The AAIF charter specifies a ‘Platinum Member Cap’ mandating that ‘at no time may there be more than eight (8) Platinum Members.’26 The current eight platinum members, as well as the platinum cap, have been in place since the launch of the AAIF.27

The AAIF is managed by a Governing Board (GB) holding responsibility over the budget, overseeing outreach, and reviewing proposals for additional projects to the foundation.28 Each platinum member is entitled to appoint a single representative to the GB, and gold members are collectively represented by a single representative. Silver and associate members have no representation on the GB – a notable departure from other LF directed funds, including the PyTorch Foundation and the CNCF (see Table 1).29 Alongside the GB, the AAIF establishes a Technical Committee (TC) for the purpose of overseeing best practices and the technical vision of the foundation.30 As for the GB, each platinum member of the AAIF is entitled to appoint one representative to the TC.31 There is no representation for gold, silver, or associate members on the TC, which again departs from other LF directed funds. For example, gold members of the PyTorch foundation have one representative on the ‘Technical Advisory Council’ per three members, which are selected by the gold members themselves (see Table 2).

Membership TierAAIFCNCFPyTorch
Platinum1 representative from each member1 representative from each member1 representative from each member
Gold1 representative1 representative per 5 members, up to a maximum of 31 representative per 3 members
SilverNone1 representative per 10 members, up to a maximum of 31 representative per 10 members, up to a maximum of 3
OtherNoneThe chair of the Technical Oversight Committee; The chair of the End User Technical Advisory Body; Two committers elected from CNCF projects1 Associate member representative; 1 representative from the Technical Advisory Council

Table 1. Governing Board representation per membership tier in the AAIF, CNCF, and PyTorch Foundation. Sources: AAIF Charter, CNCF Charter, PyTorch Charter.

Membership TierAAIF: Technical Committee (TC)CNCF: Technical Oversight Committee (TOC)CNCF: End User Technical Advisory Body (End User TAB)PyTorch: Technical Advisory Council (TAC)
Platinum1 representative from each memberN/A1 representative from each platinum end user member321 representative from each member
GoldNoneN/A1 representative per 5 gold end user members, up to a maximum of 31 representative per 3 members
SilverNoneN/A1 representative per 10 silver end user members, up to a maximum of 3None
OtherNoneGoverning Board elects 6; End user Members elect 2; Non-sandbox project maintainers elect 1; Existing TOC Members elect a further 2At least 3 by end users at large; 1 or 2 TOC members (each of whom must be employed by an end user member); 1 or more additional representatives from end user membersOne representative from each ‘TAC project’

Table 2. Technical Committee (or equivalent) representation per membership tier in the AAIF, CNCF, and PyTorch Foundation. Sources: AAIF TC Charter, CNCF Charter, PyTorch Charter.

Comparison and Discussion

Given this overview of both IETF’s and AAIF/MCP’s governance structures, the clearest difference is between the ways in which senior leadership positions are filled. Whereas all but one member of AAIF leadership are representatives of a permanent set of eight private companies and MCP leadership is by invitation only (and currently consists wholly of employees from those same eight companies), a large number of IETF leadership are elected by a random draw of engaged, rank-and-file contributors. Furthermore, while AAIF and MCP contain no pathways through which unpopular leadership can be removed by the community, IETF leadership largely serves two-year fixed terms, and can be removed by a similarly random selection of contributors. Overall, while employees of private companies are represented in both

IETF and AAIF/MCP leadership, the differences in governance structures mean that those engaged in the former are able to be held accountable to their actions by the broader community in ways which aren’t seen in AAIF/MCP.

It may be argued that the comparison is invalid: the IETF and AAIF are products of very different circumstances, working in different contexts. One could also argue that the IETF is a unique and distinctive organisation that is not without its flaws, and therefore, aiming to replicate it is misguided. However, we do not argue that governance structures employed by the IETF should be reproduced exactly in the case of the AAIF or MCP. Rather, it provides an informative demonstration of potential frameworks for promoting openness and participation in protocol development. Furthermore, when comparing the AAIF to other LF directed funds, such as CNCF and the PyTorch Foundation, a number of noteworthy differences are apparent – including the differences in GB and TC representation referenced above. First, the ‘platinum cap’ observed in the AAIF above is not found in other directed funds. Second, the AAIF charter specifies a ‘startup period’ lasting three years within which amendments to the charter, the adoption of new rules or policies, an increase to the ‘platinum cap’, and the approval of additional projects can be vetoed by platinum members that have contributed projects to the AAIF.33 This ‘startup period’ also appears to be unique to the AAIF. Finally, it is worth pointing out a number of features of the CNCF that are absent from the AAIF. The CNCF charter includes a ‘values’ section, that explicitly lists ‘neutrality’ as a core value, stating that the CNCF ‘avoid[s] influence, biased behavior, “pay-to-play” decision-making, and other activities that favor one project, individual, or organization over another’ (CNCF Charter, §3(c)). The CNCF also allows for members to be designated as ‘end user’ organisations, which explicitly excludes companies developing or distributing CNCF technologies, with a separate board (the ‘End User Technical Advisory Body’) reserved solely for such members (CNCF charter, §7-8).

When it comes to MCP itself, stewardship explicitly takes the form of a ‘Benevolent Dictator For Life’ (BDFL) model with the two lead maintainers holding ultimate decision-making authority. Since MCP’s donation to the AAIF, its governance structure has become increasingly formalised, including the provision that only lead maintainers are able to propose amendments to the governance structure [86]. At time of writing, there is also a notable amount of overlap between the MCP core maintainers, the AAIF GB, and the AAIF TC. In particular, an MCP lead maintainer is the chair of the TC, the TC co-chair is an MCP core maintainer, and a third individual is simultaneously an MCP core maintainer and a representative on both the TC and GB.34 In contrast, Kubernetes, a project under the CNCF, has a seven-member steering committee elected to two-year terms by active contributors to the project.35 A closer comparison is PyTorch, which, while also adopting a BDFL structure, includes a provision such that a super-majority of core maintainers can choose to remove the lead maintainer.36

The picture that emerges is one in which numerous design choices, each of which might seem inconsequential in isolation, collectively centralise decision-making authority in a small number of tech companies and their employees, with limited routes to community accountability or representation. This pattern is not unprecedented in the AI industry: Widder et al. [93] observe that

some companies have moved to embrace ‘open’ AI as a mechanism to entrench dominance, using the rhetoric of ‘open’ AI to expand market power while investing in ‘open’ AI efforts in ways that allow them to set standards of development while benefitting from the free labor of open source contributors.

In this context, the donation of MCP to AAIF warrants scrutiny. The donation does not affect MCP’s BDFL model and lack of mechanism for removing lead maintainers, the platinum cap restricts engagement with the AAIF at the highest levels, and the three-year startup period in the AAIF charter means that structural amendments to the foundation can be vetoed by any of Anthropic, Block, or OpenAI. This is noteworthy given the absence of any acknowledgement or policy regarding potential conflicts of interest or a ‘values’ section of the charter – as seen for CNCF.

While we do not make any claim that this authority is being abused, we note that it does create the possibility of unaccountable use of this power in ways that may not be in the broader community’s interest. Concretely, lead maintainers could steer the protocol in a direction that favours their own models or infrastructure, or block functionality that benefits competitors. Less dramatically, leadership could refuse to implement important functionality if it is not aligned with the interest of their employer(s), including some security measures.

Potential responses to these concerns include that a concentrated power structure is necessary to ensure the stability and coherence of MCP governance and strategy while the project is rapidly scaling, and that this will be relaxed once the rate of development slows. However, other than the aforementioned ‘startup period’ in the AAIF charter, there is no mention of any governance structures being time-limited. Furthermore, actions taken by leadership, such as restricting the right to propose governance amendments to lead maintainers, mean that any decision to increase accountability and representation can only be made by two people [86]. Alternatively, one might argue that contributors and community members that are unhappy with the governance structures are free to work on an alternative project, or fork the repository to proceed in a different direction. However, while such defection is theoretically possible, given MCP’s current scale and extent of corporate adoption, direct competition is likely infeasible in practice, and is further hindered by the fact that many potential corporate backers of an alternative protocol already support MCP through the AAIF. Additionally, this argument assumes that only contributors have a valid interest in how MCP is governed. However, given that MCP is often referred to by its own stewards as becoming ‘critical infrastructure for AI’ [64], it is not unreasonable for individuals who are not involved in its development to be concerned with how it is governed.

Ultimately, there is a question of legitimacy when it comes to who gets to control ‘critical infrastructure’, whether relating to the internet, AI, or otherwise. As highlighted by DeNardis [30], ‘if technical standards make public interest decisions, the questions of who sets technical standards and how they set them are highly relevant.’ While the IETF – a technocratic, small (on the order of thousands), and unrepresentative subset of the population that’s responsible for infrastructure used by billions – may not be a paragon of democratic legitimacy, its adoption of unique governance mechanisms aimed at increasing participation and accountability can provide inspiration for individuals and organisations leading the development of AI protocols. Should MCP achieve its stated aim of becoming ‘critical infrastructure for AI’ with the current governance structures in place, this would represent a significant concentration of authority over a technology with far-reaching implications, grounded primarily in the speed of its adoption.

Discussion

Overall, the preceding two sections combine to paint a cautionary picture. If steps are not taken early to implement security, the ecosystem may burden itself with a persistent security deficit with ever-increasing costs of retrofitting. This security deficit may emerge alongside entrenched governance structures that preserve corporations’ primacy with regards to long-term decision-making, while public statements emphasise community input and participation.

Notably, these conclusions may be in tension: it is plausible that the more concentrated power structure of MCP/AAIF is beneficial or even necessary for ensuring the security of MCP, since key design features that enhance security could hypothetically be prioritised from the top down. The concepts of input and output legitimacy, introduced by Scharpf [82] in the context of the European Union, and Schmidt [83]’s extension to ‘throughput’ legitimacy may be a relevant framing here, having been applied to internet governance in [66]. Input legitimacy refers to the extent to which governance is ‘by the people’ – i.e., that subjects’ views, preferences, and beliefs are taken as inputs to the governance processes. In contrast, output legitimacy refers to the extent to which governance is ‘for the people’ – i.e., that the actions or decisions taken as a result of a governance process serve subjects’ interests. Throughput legitimacy adds an intermediate layer, concerning the processes by which governance decisions are made, for example, whether they are transparent and accountable. In this paper, while we make no assessment of MCP or AAIF’s output legitimacy, instead observing multiple features of their input and throughput legitimacy. Whilst MCP’s openness to contributions from the broader community may in some cases lead to increased input legitimacy, AAIF’s cap on the number of platinum members and restricted representation on its governing board may decrease input legitimacy. Regarding throughput legitimacy, MCP’s transparency on account of it being developed open source is counteracted by limited mechanisms for holding leadership accountable for design decisions. Schmidt [83] argues further that a lack of throughput legitimacy can serve to ‘delegitimate both input and output’. In the case of MCP, this would imply that output legitimacy, perhaps in the form of increased security, could be undermined by an illegitimate development process.

In this paper we have largely focused on MCP as an archetypal case study for AI agent protocols due to its status as the most widely adopted AI agent protocol. However, the broad effects observed here concerning the practical and economic challenges of retrofitting security, and the nature of governance and representation, are generalisable regardless of the specific project in question. Should MCP become defunct or outcompeted by an alternative, we believe that whatever project takes its place will have to contend with similar security considerations. While the discussion of governance structures in § 4.2 and § 4.3 is specific to MCP and the AAIF, we focus on these structures because of MCP’s rapid uptake among users and business – making the question of how it is governed particularly consequential.

Our conclusions carry several practical implications. First, policymakers should accept that de facto standardisation can come from sources outside of traditional SDOs and policymaking institutions. NIST’s recent AI Agent Standards Initiative, which actively engages with industry-led protocols development reflects a growing acknowledgement of this reality.37 Ignoring such developments while following traditional formal standards setting processes risks being outcompeted by more nimble, industry-led efforts. Second, claims of projects being ‘open, neutral and community-driven’ should be approached with a critical eye, and judgements should be based on how such projects operate in practice, rather than public statements. Third, the observed difficulty with which security was retrofitted to internet protocols should be taken as a lower bound for that which could be faced by the ecosystem of AI agent protocols. Finally, there is an important unanswered question of designing protocol governance structures that are simultaneously nimble and maintain sufficient representation and accountability for community interests, including security, to be taken seriously. We encourage protocol developers, policymakers, and affected communities to proactively engage in debate and experimentation on this issue.

Acknowledgments

The authors would like to thank Alan Chan, Maike Osborne, Amin Oueslati, Patricia Paskov, Huw Roberts, Chris Schmitz, Merlin Stein, and Marta Ziosi for comments and feedback.

References

References

  1. [1]Josh Aas, Richard Barnes, Benton Case, Zakir Durumeric, Peter Eckersley, Alan Flores-López, J. Alex Halderman, Jacob Hoffman-Andrews, James Kasten, Eric Rescorla, Seth Schoen, and Brad Warren. 2019. Let’s Encrypt: An Automated Certificate Authority to Encrypt the Entire Web. In Proceedings of the 2019 ACM SIGSAC Conference on Computer and Communications Security (CCS ’19). Association for Computing Machinery, New York, NY, USA, 2473–2487. doi:10.1145/3319535.3363192DOI
  2. [4]Ross Anderson and Tyler Moore. 2006. The Economics of Information Security. Science 314, 5799 (2006), 610–613. https://www.jstor.org/stable/20031627pubmed.ncbi.nlm.nih.gov/17068253
  3. [5]Roy Arends, Rob Austein, Matt Larson, Dan Massey, and Scott Rose. 2005. DNS Security Introduction and Requirements. RFC 4033, https://datatracker.ietf.org/doc/rfc4033. doi:10.17487/RFC4033DOI
  4. [6]Roy Arends, Rob Austein, Matt Larson, Dan Massey, and Scott Rose. 2005. Protocol Modifications for the DNS Security Extensions. RFC 4035, https://datatracker.ietf.org/doc/rfc4035. doi:10.17487/RFC4035DOI
  5. [7]Roy Arends, Rob Austein, Matt Larson, Dan Massey, and Scott Rose. 2005. Resource Records for the DNS Security Extensions. RFC 4034, https://datatracker.ietf.org/doc/rfc4034. doi:10.17487/RFC4034DOI
  6. [8]Elaine Barker, Lily Chen, David Cooper, Dustin Moody, Andrew Regenscheid, Murugiah Souppaya, Bill Newhouse, Russ Housley, Sean Turner, William Barker, and Karen Kent. 2025. Considerations for Achieving Crypto Agility: Strategies and Practices: Technical Report CSWP 39. National Institute of Standards and Technology, Gaithersburg, MD. 39 pages. doi:10.6028/NIST.CSWP.39DOI
  7. [9]Johannes M. Bauer and Michel J. G. van Eeten. 2009. Cybersecurity: stakeholder incentives, externalities, and policy options. Telecommunications Policy 33, 10 (Nov. 2009), 706–719. doi:10.1016/j.telpol.2009.09.001
  8. [10]S. M. Bellovin. 1989. Security problems in the TCP/IP protocol suite. SIGCOMM Comput. Commun. Rev. 19, 2 (April 1989), 32–48. doi:10.1145/378444.378449
  9. [11]Tim Berners-Lee, Roy T. Fielding, and Henrik Nielsen. 1996. Hypertext Transfer Protocol – HTTP/1.0. RFC 1945, https://datatracker.ietf.org/doc/rfc1945. doi:10.17487/RFC1945
  10. [12]Matthew Bernhard, Jonathan Sharman, Claudia Ziegler Aceyman, Philip Kortum, Dan S. Wallach, and J. Alex Halderman. 2019. On the Usability of HTTPS Deployment. In Proceedings of the 2019 CHI Conference on Human Factors in Computing Systems (CHI ’19). Association for Computing Machinery, New York, NY, USA, 1–10. doi:10.1145/3290605.3300540DOI
  11. [13]Brad Biddle. 2025. Broadly Modern: Understanding the ICT Standards Development Ecosystem. doi:10.2139/ssrn.3023650
  12. [14]Harold Booth, Bill Fisher, Ryan Galluzzo, and Joshua Roberts. 2026. Accelerating the Adoption of Software and AI Agent Identity and Authorization. Technical Report. NIST, NCoE.
  13. [15]Scott O. Bradner. 1996. The Internet Standards Process – Revision 3. RFC 2026, https://datatracker.ietf.org/doc/rfc2026. doi:10.17487/RFC2026
  14. [18]Brian E. Carpenter. 1996. Architectural Principles of the Internet. RFC 1958, https://datatracker.ietf.org/doc/rfc1958. doi:10.17487/RFC1958DOI
  15. [19]Corinne Cath. 2016. Send Conservatively, Accept Liberally: Cultural Governance of Open Internet Standards. In The Politics of Open Infrastructures: Power, Governance, and Justice in Digital Knowledge Practices. Digital Humanities Series, Vol. 6. Open Book Publishers, 21–42. doi:10.11647/obp.0528.01
  16. [20]Vinton G. Cerf. 2002. The Internet is for Everyone. RFC 3271., doi:10.17487/RFC3271DOI
  17. [21]Vinton G. Cerf, Yogen Dalal, and Carl Sunshine. 1974. Specification of Internet Transmission Control Program. RFC 675, https://datatracker.ietf.org/doc/rfc675. doi:10.17487/RFC0675
  18. [22]Alan Chan, Kevin Wei, Sihiao Huang, Nirtashan Rajkumar, Elija Perrier, Seth Lazar, Gillian K. Hadfield, and Markus Anderljung. 2025. Infrastructure for AI Agents. Transactions on Machine Learning Research (Feb. 2025). https://openreview.net/forum?id=Ckhl7xN2R2
  19. [23]David D Clark. 1992. A Cloudy Crystal Ball – Visions of the Future. https://groups.csail.mit.edu/ana/People/DDC/future_ietf_92.pdf. https://groups.csail.mit.edu/ana/People/DDC/future_ietf_92.pdf
  20. [25]Steve Crocker, Dr Jon Postel, J. Newkirk, and M. Kraley. 1970. Official Protocol Proffering. RFC 54, https://datatracker.ietf.org/doc/rfc54. https://datatracker.ietf.org/doc/rfc54DOI
  21. [26]Stephen D. Crocker. 1987. The Origins of RFCs. RFC 1000, https://datatracker.ietf.org/doc/rfc1000. doi:10.17487/RFC1000
  22. [27]Steve E. Deering and Bob Hinden. 1998. Internet Protocol, Version 6 (IPv6) Specification. RFC 2460, https://datatracker.ietf.org/doc/rfc2460. doi:10.17487/RFC2460
  23. [28]Den Delimarsky. 2025. What’s New In The 2025-11-25 MCP Authorization Spec. https://den.dev/blog/mcp-november-authorization-spec/. https://den.dev/blog/mcp-november-authorization-spec/
  24. [29]Laura DeNardis. 2007. A history of internet security. In The History of Information Security: A Comprehensive Handbook, Karl De Leeuw and Jan Bergstra (Eds.). Elsevier Science B.V., 681–704. doi:10.1016/B978-044451608-4/50025-0DOI
  25. [30]Laura DeNardis. 2009. Protocol Politics: The Globalization of Internet Governance. MIT Press, Cambridge, UNITED STATES. http://ebookcentral.proquest.com/lib/oxford/detail.action?docID=3339043DOI
  26. [31]Tim Dierks and Christopher Allen. 1999. The TLS Protocol Version 1.0. RFC 2246, https://datatracker.ietf.org/doc/rfc2246. doi:10.17487/RFC2246
  27. [32]Martin D unke. 2023. Nomination Committee Eligibility. RFC 9389, https://datatracker.ietf.org/doc/rfc9389. doi:10.17487/RFC9389
  28. [33]Donald E. Eastlake 3rd. 2004. Publicly Verifiable Nominations Committee (NomCom) Random Selection. RFC 3797, https://datatracker.ietf.org/doc/rfc3797. doi:10.17487/RFC3797
  29. [34]Abdul Ehtesham, Aditi Singh, Gaurav Kumar Gupta, and Saket Kumar. 2025. A survey of agent interoperability protocols: Model Context Protocol (MCP), Agent Communication Protocol (ACP), Agent-to-Agent Protocol (A2A), and Agent Network Protocol (ANP). arXiv:2505.02279 [cs]. doi:10.48550/arXiv.2505.02279
  30. [35]T. Eisenberg, D. Gries, J. Hartmanis, D. Holcomb, M. S. Lynn, and T. Santoro. 1989. The Cornell commission: on Morris and the worm. Commun. ACM 32, 6 (June 1989), 706–709. doi:10.1145/63526.63530
  31. [37]Sophie Faaborg-Anderson and Lindsay Temes. 2022. The Geopolitics of Digital Standards. Technical Report. The Belfer Center for Science and International Affairs, Cambridge, MA, USA. https://www.belfercenter.org/publication/geopolitics-digital-standards
  32. [38]Adrienne Porter Felt, Richard Barnes, April King, Chris Palmer, Chris Bentzel, and Parisa Tabriz. 2017. Measuring HTTPS Adoption on the Web. 1323–1338. https://www.usenix.org/conference/usenixsecurity17/technical-sessions/presentation/felt
  33. [39]Adrienne Porter Felt, Robert W. Reeder, Alex Ainslie, Helen Harris, Max Walker, Christopher Thompson, Mustafa Emre Acer, Elisabeth Morant, and Sunny Consolvo. 2016. Rethinking Connection Security Indicators. 1–14. https://www.usenix.org/conference/soups2016/technical-sessions/presentation/porter-felt
  34. [40]Matija Franklin, Nenad Tomašev, Julian Jacobs, Joel Z. Leibo, and Simon Osindero. 2026. AI Agent Traps. doi:10.2139/ssrn.6372438DOI
  35. [41]Lawrence A. Gordon, Martin P. Loeb, William Lucyshyn, and Lei Zhou. 2015. Externalities and the Magnitude of Cyber Security Underinvestment by Private Sector Firms: A Modification of the Gordon-Loeb Model. Journal of Information Security 6, 1 (Jan. 2015), 24–30. doi:10.4236/jis.2015.61003DOI
  36. [42]Deepak Gouda, Romain Fontugne, and Cecilia Testart. 2025. ru-RPKI-ready: the Road to Full ROA Adoption. In Proceedings of the 2025 ACM Internet Measurement Conference (IMC ’25). Association for Computing Machinery, New York, NY, USA, 415–429. doi:10.1145/3730567.3764452
  37. [44]Alison Haur, George Christou, and Seamus Simpson. 2020. Internal Governance of the IETF, W3C, OASIS, and IEEE: Structure, Decision-making, and Internationalization. In Global Standard Setting in Internet Governance, Alison Harcourt, George Christou, and Seamus Simpson (Eds.). Oxford University Press, 0. doi:10.1093/oso/9780198841524.003.0003
  38. [45]Dick Hardt. 2012. The OAuth 2.0 Authorization Framework. RFC 6749, https://datatracker.ietf.org/doc/rfc6749. doi:10.17487/RFC6749DOI
  39. [46]Xinyi Hou, Yanjie Zhao, Shenao Wang, and Haoyu Wang. 2026. Model Context Protocol (MCP): Landscape, Security Threats, and Future Research Directions. ACM Trans. Softw. Eng. Methodol. (Feb. 2026). doi:10.1145/3796519DOI
  40. [47]IAB. 1989. Ethics and the Internet. RFC 1087,. doi:10.17487/RFC1087DOI
  41. [48]ITU. 2025. Requirements and evaluation methods of artificial intelligence agents based on large scale pre-trained models. https://www.itu.int/rec/T-REC-F.748.46-2025-3/en
  42. [49]Tibor Jager, Kenneth G Paterson, Royal Holloway, and Juraj Somorovsky. 2013. One Bad Apple: Backwards Compatibility Attacks on State-of-the-Art Cryptography. https://www.ndss-symposium.org/ndss2013/ndss-2013-programme/one-bad-apple-backwards-compatibility-attacks-state-art-cryptography/
  43. [50]Michael B. Jones, John Bradley, Maciej Machulak, and Phil Hunt. 2015. OAuth 2.0 Dynamic Client Registration Protocol. RFC 7591, https://datatracker.ietf.org/doc/rfc7591. doi:10.17487/RFC7591
  44. [51]Prashant Khare, Mladen Karan, Stephen McQuistin, Colin Perkins, Gareth Tyson, Matthew Purver, Patrick Healey, and Ignacio Castro. 2022. The web we weave: Untangling the social graph of the IETF. In Proceedings of the International AAAI Conference on Web and Social Media, Vol. 16. 500–511. https://ojs.aaai.org/index.php/ICWSM/article/view/19310DOI
  45. [52]Hee-Woong Kim and Atreyi Kankanhalli. 2009. Investigating user resistance to information systems implementation: a status quo bias perspective. MIS Q. 33, 3 (Sept. 2009), 567–582.
  46. [53]Katharina Krombhōlz, Wilfried Mayer, Martin Schmiedecker, and Edgar Weippl. 2017. ”I Have No Idea What I’m Doing” - On the Usability of Deploying HTTPS. 1339–1356. https://www.usenix.org/conference/usenixsecurity17/technical-sessions/presentation/kromholz
  47. [54]Murray Kucherawy, Bob Hinden, and Jason Livingood. 2020. IAB, IESG, IETF Trust, and IETF LLC Selection, Confirmation, and Recall Process: Operation of the IETF Nominating and Recall Committees. RFC 8713, https://datatracker.ietf.org/doc/rfc8713. doi:10.17487/RFC8713DOI
  48. [55]Brenden Kuerbis and Milton Mueller. 2020. The hidden standards war: economic factors affecting IPv6 deployment. Digital Policy, Regulation and Governance 22, 4 (Nov. 2020), 333–361. doi:10.1108/DPRG-10-2019-0085DOI
  49. [56]Pankaj Kumar and Subhankar Mishra. 2025. Robustness in Large Language Models: A Survey of Mitigation Strategies and Evaluation Metrics. arXiv:2505.18658 [cs.CL]. doi:10.48550/arXiv.2505.18658DOI
  50. [57]Howard Kunreuther and Geoffrey Heal. 2003. Interdependent Security. Journal of Risk and Uncertainty 26, 2/3 (2003), 231–249. https://www.jstor.org/stable/41755017
  51. [58]Barry M. Leiner, Vinton G. Cerf, David D. Clark, Robert E. Kahn, Leonard Kleinrock, Daniel C. Lynch, Jon Postel, Larry G. Roberts, and Stephen Wolff. 2009. A brief history of the internet. SIGCOMM Comput. Commun. Rev. 39, 5 (Oct. 2009), 22–31. doi:10.1145/1629607.1629613DOI
  52. [59]Matt Lepinski and Stephen Kent. 2012. An Infrastructure to Support Secure Internet Routing. RFC 6480, https://datatracker.ietf.org/doc/rfc6480. doi:10.17487/RFC6480DOI
  53. [60]Kim Martineau. 2025. An open-source protocol for AI agents to interact. https://research.ibm.com/blog/agent-communication-protocol-ai. https://research.ibm.com/blog/agent-communication-protocol-ai
  54. [61]David Nalley. 2026. AAIF’s First Quarter Success Story: New Members, Technical Wins, and Open Governance. https://aaif.io/blog/aaifs-first-quarter-success-story-new-members-technical-wins-and-open-governance/. https://aaif.io/blog/aaifs-first-quarter-success-story-new-members-technical-wins-and-open-governance/
  55. [62]Luca Nannini, Adam Leon Smith, Michele Joshua Maggini, Enrico Panai, Sandra Feliciano, Aleksandr Tiulkanov, Elena Maran, James Gealy, and Piercosma Bisconti. 2026. AI Agents Under EU Law. arXiv:2604.04604v1 [cs]. doi:10.48550/arXiv.2604.04604DOI
  56. [63]David Naylor, Alessandro Finamore, Ilias Leontiadis, Yan Grunenberger, Marco Mellia, Maurizio Munafò, Konstantina Papagiannaki, and Peter Steenkiste. 2014. The Cost of the "S" in HTTPS. In Proceedings of the 10th ACM International on Conference on emerging Networking Experiments and Technologies (CoNEXT ’14). Association for Computing Machinery, New York, NY, USA, 133–140. doi:10.1145/2674005.2674991
  57. [64]Rithula Nisha. 2025. How Linux Foundation Unifies Open Standards for AI Agents. AI Magazine (Dec. 2025). https://aimagazine.com/news/one-rule-for-all-agents-linux-foundation-launches-aaif
  58. [65]Andy Ozment and Stuart E Schechter. 2006. Bootstrapping the Adoption of Internet Security Protocols. In Proceedings of the Fifth Workshop on the Economics of Information Security. https://weis2006/doc/48/36.pdf
  59. [66]Nicola Palladino and Mauro Santaniello. 2021. Legitimacy, Power, and Inequalities in the Multistakeholder Internet Governance: Analyzing IANA Transition. Springer International Publishing, Cham. doi:10.1007/978-3-030-56131-4DOI
  60. [67]Aaron Parecki. 2025. Let’s fix OAuth in MCP. https://aaronparecki.com/2025/04/03/15/oauth-for-model-context-protocol. https://aaronparecki.com/2025/04/03/15/oauth-for-model-context-protocol
  61. [68]James L. Pelkey. 1988. Interview of Steve Crocker. Technical Report. Computer History Museum. https://archive.computerhistory.org/resources/access/text/2017/12/102738690-05-01-acc.pdf. https://archive.computerhistory.org/resources/access/text/2017/12/102738690-05-01-acc.pdf
  62. [69]Greta L. Polites and Elena Karahanna. 2012. Shackled to the Status Quo: The Inhibiting Effects of Incumbent System Habit, Switching Costs, and Inertia on New System Acceptance. Management Information Systems Quarterly 36, 1 (March 2012), 21–42. doi:10.2307/41410404
  63. [70]Jon Postel. 1981. Internet Protocol. RFC 791, https://datatracker.ietf.org/doc/rfc791. https://datatracker.ietf.org/doc/html/rfc791
  64. [71]Jon Postel. 1981. Transmission Control Protocol. RFC 793, https://datatracker.ietf.org/doc/rfc793. https://datatracker.ietf.org/doc/html/rfc793
  65. [72]Jon Postel and Joyce K. Reynolds. 1997. Instructions to RFC Authors. RFC 2223, https://datatracker.ietf.org/doc/rfc2223. doi:10.17487/RFC2223DOI
  66. [74]Elissa M. Redmiles, Michelle L. Mazurek, and John P. Dickerson. 2018. Dancing Pigs or Externalities? Measuring the Rationality of Security Decisions. In Proceedings of the 2018 ACM Conference on Economics and Computation (EC ’18). Association for Computing Machinery, New York, NY, USA, 215–232. doi:10.1145/3219166.3219185DOI
  67. [75]Eric Rescorla. 2000. HTTP Over TLS. RFC 2818, https://datatracker.ietf.org/doc/rfc2818. doi:10.17487/RFC2818DOI
  68. [76]Pete Resnick. 2014. On Consensus and Humming in the IETF. RFC 7282, https://datatracker.ietf.org/doc/rfc7282. doi:10.17487/RFC7282DOI
  69. [77]A.L. Russell. 2006. ’Rough Consensus and Running Code’ and the Internet-OSI Standards War. IEEE Annals of the History of Computing 28, 3 (July 2006), 48–61. doi:10.1109/MAHC.2006.42
  70. [78]Andrew L. Russell. 2013. The internet that wasn’t. IEEE Spectrum 50, 8 (Aug. 2013), 39–43. doi:10.1109/MSPEC.2013.6565559DOI
  71. [79]Andrew L. Russell. 2014. The Internet and the Advantages of Autocratic Design, 1970s–1990s. In Open Standards and the Digital Age: History, Ideology, and Networks (1 ed.). Cambridge University Press. doi:10.1017/CBO9781139856553
  72. [80]Rich Salz. 2022. Entities Involved in the IETF Standards Process. RFC 9281, https://datatracker.ietf.org/doc/rfc9281. doi:10.17487/RFC9281DOI
  73. [81]William Samuelson and Richard Zeckhauser. 1988. Status quo bias in decision making. Journal of Risk and Uncertainty 1, 1 (March 1988), 7–59. doi:10.1007/BF00055564DOI
  74. [82]Fritz Scharpf. 1999. Governing in Europe: Effective and Democratic? Oxford University Press. doi:10.1093/acprof:oso/9780198295457.001.0001DOI
  75. [83]Vivien A. Schmidt. 2013. Democracy and Legitimacy in the European Union Revisited: Input, Output and ‘Throughput’. Political Studies 61, 1 (2013), 2–22. doi:10.1111/j.1467-9248.2012.00962.xDOI
  76. [84]Tony Scott. 2015. Policy to Require Secure Connections across Federal Websites and Web Services. https://obamawhitehouse.archives.gov/sites/default/files/omb/memoranda/2015/m-15-13.pdf. https://obamawhitehouse.archives.gov/sites/default/files/omb/memoranda/2015/m-15-13.pdf
  77. [85]OX Security. 2026. The Mother of All AI Supply Chains: Anthropic’s “By Design” failure at the heart of the AI ecosystem. https://www.ox.security/reports/the-mother-of-all-ai-supply-chains-anthropics-by-design-failure-at-the-heart-of-the-ai-ecosystem/
  78. [86]David Soria Parra. 2025. Governance Succession and Amendment Procedures. SEP-2085, https://modelcontextprotocol.io/seps/2085-governance-succession-and-amendment. https://modelcontextprotocol.io/seps/2085-governance-succession-and-amendment
  79. [87]David Soria Parra and Sarah Novotny. 2026. MCP Contributor Ladder. SEP-2148, https://modelcontextprotocol.io/seps/2148-contributor-ladder. https://modelcontextprotocol.io/seps/2148-contributor-ladder
  80. [88]Merlin Stein. 2026. How are AI agents used? Evidence from 177,000 MCP tools. arXiv:2603.23802 [cs]. doi:10.48550/arXiv.2603.23802
  81. [89]Rao Surapaneni, Miku Jha, Michael Vakoc, and Todd Segal. 2025. Announcing the Agent2Agent Protocol (A2A). https://developers.googleblog.com/en/a2a-a-new-era-of-agent-interoperability/. https://developers.googleblog.com/en/a2a-a-new-era-of-agent-interoperability/
  82. [90]Malou van Draanen Glismann and Graham Webster. 2025. Lexicon: How China talks about ’agentic AI’. https://digichina.stanford.edu/work/lexicon-how-china-talks-about-agentic-ai/. https://digichina.stanford.edu/work/lexicon-how-china-talks-about-agentic-ai/
  83. [91]Hal Varian. 2004. System Reliability and Free Riding. In Economics of Information Security, L. Jean Camp and Stephen Lewis (Eds.). Vol. 12. Kluwer Academic Publishers, Boston, 1–15. Series Title: Advances in Information Security. doi:10.1007/1-4020-8090-5_1
  84. [92]David Waitzman. 1990. Standard for the transmission of IP datagrams on avian carriers. RFC 1149, https://datatracker.ietf.org/doc/rfc1149. doi:10.17487/RFC1149DOI
  85. [93]David Gray Widder, Sarah West, and Meredith Whittaker. 2023. Open (For Business): Big Tech, Concentrated Power, and the Political Economy of Open AI. doi:10.2139/ssrn.4543807DOI
  86. [94]Michael Wooldridge. 2009. An Introduction to MultiAgent Systems (second ed.). John Wiley & Sons. https://www.cs.ox.ac.uk/people/michael. wooldridge/pubs/imas//IMAS2e.html
  87. [95]Peng Wu, Yong Cui, Jianping Wu, Jiangchuan Liu, and Chris Metz. 2013. Transition from IPv4 to IPv6: A State-of-the-Art Survey. IEEE Communications Surveys & Tutorials 15, 3 (2013), 1407–1424. doi:10.1109/SURV.2012.101112.00200DOI
  88. [96]Yingxuan Yang, Huacan Chai, Yuanyi Song, Siyuan Qi, Muning Wen, Ning Li, Junwei Liao, Haoyi Hu, Jianghao Lin, Gaowei Chang, Weiwen Liu, Ying Wen, Yong Yu, and Weinan Zhang. 2025. A Survey of AI Agent Protocols. arXiv:2504.16763v3 [cs]. https://arxiv.org/abs/2504.16763v3
  89. [97]Robert H. Zakon. 1997. Hobbes’ Internet Timeline. RFC 2235, https://datatracker.ietf.org/doc/rfc2235. doi:10.17487/RFC2235DOI
  90. [99]Huijun Zhou, Xiaohan Zhang, Haozhe Zhang, Haoyang Zhang, Mi Zhang, and Min Yang. 2026. A First Measurement Study on Authentication Security in Real-World Remote MCP Servers. arXiv:2605.22333 [cs.CR]. doi:10.48550/arXiv.2605.22333DOI

Paper details

vlnc:W_kqy3dnnx
v1 · latestHistory (1)

published · Fresh — added to the Hub within the last 30 days

added ·

Usage

views · 8

downloads · 0

A view counts once per browser per day, a download each time the PDF is requested.

CC BY 4.0

Original source

  • Computer Science

Not recorded for this paper · View statement →

Looking for related papers…
Contents